Grub und Fedora

Da Fedora 14 bei der Installation nicht die Ubuntu-Installation in das Grub-Startmenü aufgenommen hatte, musste ich die Sache folgendermaßen korrigieren:

# sudo gedit /boot/grub/menu.lst   

title Kubuntu 10.04  
    root=(hd0,2)  
    kernel  /boot/vmlinuz-2.6.32-25-generic-pae root=UUID=39777864-fd5b-48d2-870f-014f6c2702d3 ro   quiet splash  
    initrd  /boot/initrd.img-2.6.32-25-generic-pae  


# grub-install /dev/sda  
# reboot  
Tags: 

Innosetup - Nach der Installation eine Datei kopieren

Nach der Installation soll eine Datei in Abhängigkeit von der Windowsversion in ein Verzeichnis kopiert werden.

Die Datei qf steht im Installationsverzeichnis bereit.

Das Zielverzeichnis zv soll ab Windows-Vista das Verzeichnis
C:\Users\user_name\Appdata\Local\ sein. In älteren Windowsversionen wird die Datei im Programmverzeichnis gespeichert.

[Code]  
procedure CurStepChanged(CurStep: TSetupStep);  
var qf,zf,zv:string;  
  Version: TWindowsVersion;  
begin  
  if CurStep = ssPostInstall then begin  
    GetWindowsVersionEx(Version);  
    if Version.Major>=6 then  
      zv:=ExpandConstant('{localappdata}\wnftest\')  
    else  
      zv:=ExpandConstant('{app}\');  
    qf:=ExpandConstant('{src}\einstellungen.dat');  
    zf:=zv+'kita_fb.liz';  
    MsgBox(IntToStr(Version.Major)+#13+  
      qf+#13+zv+#13+zf, mbInformation, MB_OK);  
    forcedirectories(zv);  
    FileCopy( qf, zf,FALSE);  
    end  
end;  

KDE4 Dolphin wird langsam

Ich habe überhaupt nichts gemacht ... ;-)

aber mein Dolphin (und auch einige andere Datei-Öffnen-Dialoge unter KDE 4.5.0) wurde unerträglich langsam. Das Öffnen des Verzeichnisses Bilder dauerte eine Minute.

Es könnte daran gelegen haben dass ich unter Systemeinstellungen die Desktopsuche deaktiviert hatte.

Lange Rede kurzer Sinn: Nachdem ich in Dolphin - Einstellungen - Dolphin einrichten - die Voreinstellungen aktiviert habe, startet Dolphin jetzt wieder wie gewohnt schnell und zuverlässig.

Linux Grub2

Bei ubuntuusers.de findet man

nach Kernelupdate oder Installation von anderen Betriebssystemen auf anderen Partitionen:

sudo update-grub  

GRUB 2 erneut in den MBR der Festplatte oder Bootsektor einer Partition installieren

Die Kernkomponenten von GRUB 2 - boot.img und core.img - in den MBR und den verborgenen Bereich oder Bootsektor schreiben:

sudo grub-setup /dev/sda   

sda ist dabei an das eigene System anzupassen.

Win7 schläft unter VMWare ein

Ich arbeite schon seit mehreren Jahren mit meinem alten W2K in VMWare auf Kubuntu. Seit ich jedoch mit Win7 arbeite schläft meine VMWare Maschine in der Mittagspause ein und wacht danach nicht wieder richtig auf. Mir geht es genauso aber mit einer Tasse Kaffee ist bei mir das Problem beseitigt.

Hier fand ich die Lösung für meine VMWare-Maschine

  • vm.swappiness=0 in die Datei /etc/sysctl.conf eintragen
  • VMWare als root starten und dann unter Edit/Prereferences/Memory "Fit all virtual machine memory into reserved host RAM" auswählen.

vmware_preferences_fit

Tags: 

Thunderbird 3 ignoriert die Einstellung des network.protocol-handler

Unter Thunderbird 2 konnte man unter about:config festlegen, welcher Browser beim Klick auf einem Link aufgerufen wird.

network.protocol-handler.app.http       /usr/bin/opera  
network.protocol-handler.app.https      /usr/bin/opera  

Seitdem Umstieg auf Kubuntu 10.04 wird Thunderbird 3 benutzt und beim Klick auf einen Link öffnet sich Firefox.

Hier fand ich die Lösung

Einfach in Thunderbird unter Bearbeiten-Einstellungen-Erweitert-Konfiguration bearbeiten die Werte auf true setzen:

network.protocol-handler.warn-external.http=true  
network.protocol-handler.warn-external.https=true  

Wenn jetzt wieder auf einen Link geklickt wird, dann fragt Thunderbird nach welcher Browser genutzt werden soll. Man wählt seinen Opera aus (/usr/bin/opera) und schon funktioniert alles wie gehabt. Ich weiß jetzt zwar immer noch nicht, wo die Werte gespeichert werden, aber was solls.

Kubuntu 10.04

Also das Upgrade von Kubuntu 9.10 auf 10.04 ging erst einmal daneben:

07_11_04_rimg0090

07_11_30_rimg0091

Da bleibt mir viel Arbeit fürs Wochenende.

Die Ursache für diese Fehlermeldung war, dass die Datei /etc/fstab einen falschen Eintrag für das Einhängen der Swap-Partition hatte. Es fehlte der Eintrag für den Einhängepunkt "none". Nach dem ich auf dem Rechner ein anderes Linux hochgefahren und den Eintrag korrigiert hatte:
von

#UUID=3688e91d-06d9-446b-b1ad-101da1820278  swap  sw 0 0  

auf

/dev/sda1   none swap sw  0  0  

konnte ich meinen Rechner auch wieder starten.

Danach stürzte der X-Server ab, weil ich eine eigenen Nvidia-Treiber installierte hatte. Dieser lies sich jedoch einfach neu kompilieren.

Seiten